Skip to main content

Migration to v5

v5.0

Chart.js v4 and react-chartjs-2 v5 are ESM-only packages. To use them in your project, it also should be ESM:

package.json
{
"type": "module"
}

v5.1

Chart.js v4.1 and react-chartjs-2 v5.1 have restored the CommonJS support.