Skip to main content

Using with Chart.js v3

If your app needs Chart.js v3, please use a compatible version of this library:

yarn add chart.js@^3.9.1 react-chartjs-2@^4.3.1

Also, please consider upgrading your app to Chart.js v3.

Upgrading to Chart.js v4

First, upgrade packages. You'll need to install Chart.js v3 and the latest version of this library:

yarn add chart.js@^4.0.0 react-chartjs-2@^5.0.0

Then, please follow the this guide.